Problemas con .gitignore

git and vim

Trasteando con jekyll me he topado con un problema que estaba empezando a causarme un dolor de cabeza. El caso que el fichero .gitignore del proyecto no funcionaba si tenía más de una línea lo cual es un problemón. El problema era que el final de línea no era correcto, no se el motivo, tal vez la última actualización de LMDE, no lo se.

La solución si usas vim

:set ff=unix

Vía .gitignore file not ignoring.